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This manual provides complete information for operating
the Fax and Telephony Solutions software.

It is assumed that you are familiar with basic Macintosh
desktop operations. If not, refer to the manuals that came
with your Macintosh.

m Chapter 1  introduces the fax software for sending and
receiving faxes with your Macintosh and guides you through
the steps for sending your first fax. Everything you need to
get started is included in this chapter.

m Chapter 2 provides more complete information on the Fax
Terminal program. It covers in detail setting up your fax
environment, sending, receiving, monitoring, and managing
faxes.

m Chapter 3 covers the use of the Fax Viewer program for
viewing, editing, and printing received fax documents, as
well as OCR (Optical Character Recognition) software for
converting fax images to text.

m Chapter 4 covers the use of the Fax Cover program for
creating and installing custom fax cover pages for use with
Fax Terminal.
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m Chapter 5 covers the use of Fax Sender GX for sending fax
documents with QuickDraw GX, imaging and printing
software which is part of System 7.5.

m Chapter 6 covers the use of Apple Fax Gateway for
PowerTalk™, which allows you to send fax documents using
applications that support the PowerTalk Mailer and for your
received faxes to appear in your PowerTalk Universal
Mailbox. 

m Chapter 7 covers the use of the AppleTel™ telephony
program. AppleTel brings screen-based telephony functions
such as automatic dialing and voice mail to your computer.

x



In this chapter

m Sending your first fax

m Receiving and printing a fax

Before you begin

Please make sure that you have installed the hardware and
software according to the instructions in the hardware setup
guide included in your package.

1
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Sending your first fax

This section shows you how to get started by sending an
easy first fax. Use this first fax exercise as a tutorial, then
explore more advanced features in Chapter 2, “Getting the
Most Out of Your Fax Software.”

If you have QuickDraw GX installed in your system, read this
chapter, then read Chapter 5, “Using Fax Sender GX.”

Faxing is like printing

It is important to understand that sending a fax is just like
printing to a remote printer. Any document or window that
can be printed by an application or by the system can be
imaged and transmitted to a fax machine using the Fax
Software. The following example leads you through the steps
of faxing a document from an application using the
SimpleText document “My first fax,” which has been
provided for your convenience.

1 Open the Telecom Applications folder, then open the Fax
Folder, then open “My first fax” by double-clicking it.
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2 Hold down the Control and Shift keys while choosing Print
from the File menu. (Feature not available if you are using
Fax Sender GX.)

The Fax Sender dialog box appears just as the Print dialog
would appear if you printed the document.

Important Step 2 is a shortcut. You can also select Fax
Sender in the Chooser (see Chapter 2, “Selecting Fax
Sender”). The shortcut in step 2 works with all programs.
With some older versions of system software, the menu item
changes from Print to Fax, but the result is the same,
regardless of the item name.
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3 In the Fax Quick Send field, type the fax number of your
recipient.

By entering the recipient’s phone number, you have done
everything necessary for the transmission of your document.
You may want to include information about yourself, the
sender, on a cover page.

4 Click the Options button.

The Options dialog box appears. Make sure you select Tone
or Pulse according to the type of phone you have.

4 Chapter 1

If you need to dial additional digits 
(area or country codes) from your present
location, place them in the Dial Prefix field.

Put the recipient’s fax number in
the Fax Quick Send field.



5 To save the information you entered, click OK.

You return to the Fax Sender dialog box.

By setting the dial type (tone or pulse) and entering the
recipient’s phone number, you have done everything
necessary for the transmission of your document. You may
want to include information about yourself, the sender, on a
cover page.

6 To fill in sender information, click the Cover Info button.

Type information about yourself in the Cover Info dialog
box. To move from field to field, use the Tab key. The
information you type here will appear on your fax cover
page.

7 To save the information you’ve entered, click OK.

The Fax Sender dialog box reappears.
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can be any
combination of
letters and
numbers you
wish to identify
your fax with.Type any special messages in the Notes field.



8 To see your first fax before sending, click the Preview button.

Preview displays the fax with the cover page. The cover page
selected is the Standard cover page. The sender information
you entered in the Cover Info dialog box is displayed during
preview. Click the right arrow in the scroll bar at the bottom
of the Preview dialog box to view the other page of your fax.

9 Click Send to transmit your fax.

Your fax is transmitted immediately.

10 To monitor the sending of your fax, choose Fax Terminal
from the Application menu at the right end of the menu bar.
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Application menu icon.

Fax Terminal appears in the
Application menu shortly after
you click Send.



Fax Terminal appears.

Should transmission fail on the first attempt, Fax Sender
automatically retransmits your fax twice. (You can change
the number of retries in Fax Terminal Preferences; see
“Setting Preferences” in Chapter 2.)

9 Choose Fax Log in the Fax Terminal Windows menu.

Once the fax is sent, you can check transmission results in
the Fax Log. You have sent your first fax, and, equally
important, you have verified that transmission was
successful.

7Fax Software Quick Start

The status window displays
a series of messages during
transmission.



If Fax Terminal will not open

Fax Terminal will open in the background only if sufficient
memory is available. 

m If you are expecting a fax, you may want to quit any
unnecessary applications to free up memory.

m If Fax Terminal does not open, it may also be a result of the
current setting in the Fax Terminal Preferences. Even if Fax
Terminal doesn’t open during reception, fax reception will
occur without problem.

See also: “Setting Preferences” in Chapter 2. 

Receiving faxes

Your fax software can also receive faxes. Like an office fax
machine, it works unattended, so you can be away from
home or office and still receive faxes. If you are working on
your computer when a fax arrives, reception occurs in the
background, so it won’t interfere with your other activity.

By default, the fax software is not set to receive faxes when it
is installed. You must enable auto-answer by checking the
Auto-Answer checkbox in the Fax Terminal Preferences
dialog box or choosing Auto-Answer from the Fax menu.

To receive a fax unattended, you must leave your Macintosh
turned on, but none of the fax programs need be open.
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Preparing to receive faxes

1 Choose Fax Terminal from the Apple menu (K).

Fax Terminal opens.

2 Choose Auto-Answer from the Fax menu.

This choice automatically sets the Auto-Answer checkbox in
Fax Terminal Preferences.

See also: “Setting Preferences” in Chapter 2.

Checking for received faxes

1 Look for the Fax Terminal icon blinking over the Application
menu on the menu bar.

The Application menu is located at the right side of the
menu bar.

The blinking icon tells you that a fax is waiting in the
Received Fax Documents folder.
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2 Choose Fax Terminal from the Application menu or the
Apple Menu (K).

Fax Terminal appears.

3 To select the received fax you wish to view, click its name in
the Fax Terminal queue, then click Open.

You can also manage fax reception yourself.

See also: “Receiving Manually” in Chapter 2.
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Opening a document in the Fax Terminal queue
automatically opens Fax Viewer and your fax appears in a Fax
Viewer window.

4 To set up your fax for printing, choose Page Setup, then
choose Print from the File menu.

You can use Fax Viewer to prepare your fax for printing,
forwarding, or saving.

See also: Chapter 3, “Fax Viewer”, for a complete reference
of the Fax Viewer features.

Most of the time you will want to print only incoming faxes.
Fax Viewer handles printing in the same way any other
Macintosh program does.
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In this chapter

m Setting up your fax environment

m Sending faxes using Fax Sender

m Receiving and opening faxes

m Monitoring and managing faxes

Before you begin

Review the material in Chapter 1 to make sure you
understand the basic steps of fax operation.

13
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Setting up the fax environment

In the previous chapter you learned the basic steps for
sending and monitoring a fax. If you send faxes only
occasionally, that may suffice. However, you can take
advantage of advanced features by setting up Fax Terminal
for your own environment.

Entering fax station information

This information provides your return address as it appears
on the cover page, allowing the recipient to identify you.
You can enter this information in either the Fax Sender Fax
Cover Info dialog box or the Fax Terminal Info dialog box. 
If you makes changes in one place, they are reflected in 
the other.

1 Open Fax Terminal.

2 Choose Fax Terminal Info from the Fax menu.

A Fax Terminal Info dialog box appears.

3 Type information in the various fields of the dialog box.

4 Click OK to save the Fax Terminal information.

14 Chapter 2

Station ID is a 20-character header line identification of
your choice. If your recipient’s fax device has the capability,
Station ID is printed on the top of each page of the fax
document, along with the date and time.



Setting Preferences

The Preferences dialog box controls many useful fax settings.

1 Choose Preferences from the Fax Terminal Fax menu.

The Preferences dialog box appears.

2 Click the options to make your choices.

Table 2-1 summarizes the choices available.

Note: If you select None for error notification in the
Preferences dialog box, Fax Terminal does not interrupt
sending a batch of faxes if a single fax fails for any reason.

3 To save your Preferences, click OK.
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Select this box to
save fax image 
files.

Displays notification for received faxes, manual dial, and errors. 
A batch of faxes may be interrupted by one unsuccessful fax. 
Selecting None allows a batch of faxes to be sent without 
interruption. Unsuccessful faxes can be resent.

Sets Fax Terminal
to answer
incoming calls. 

Choose the appropriate 
modem type from this 
pop-up menu. 

Appears in certain
configurations.
Choose the port to
which your modem 
is attached.

Check these if the
remote fax doesn’t
support V17 & ECM.



Warning Fax image files can be quite large. If you frequently
receive large files, be sure that you have enough free space
on your hard disk. Fax reception fails if your disk is full.

Table 2-1 Fax Terminal Preferences dialog options

PREFERENCE FIELDS RESULT

Modem choice pop-up Choose the type that corresponds 
to your modem.

Port choice pop-up Choose the port to which your 
modem is attached, if you have an 
external modem. Does not appear in 
some configurations.

Show Fax Terminal Allows Fax Terminal window to be
window displayed automatically during send 

and receive. If not selected, you can 
still activate it during send or receive.

Save fax image files Faxes are transmitted and received as 
image files. This checkbox allows 
saving sent fax image files. Fax image 
files take up disk space and the files 
can always be re-imaged if you need to 
resend them. So, unless you frequently 
resend or forward sent faxes, you may 
want to disable saving image files.

Turn off V.17 If the remote fax supports V.17
(high speed), you may uncheck this.

Turn off ECM If the remote fax supports ECM (Error 
Correction Mode) you may uncheck 
this.

16 Chapter 2



Fax Terminal Preferences dialog options (continued)

PREFERENCE FIELDS RESULT 

Auto-Answer Must be checked to receive faxes 
(unchecked by default) automatically. If unchecked, you

may still receive manually. Review 
procedures in “Receiving a fax” in 
this chapter.

When sending fails
Retry Sets the number of retries.

Time between tries Sets the time between tries.

Resend all pages Resends the entire fax if transmission 
fails.

Resend only those Sends only the pages that failed to 
pages not already sent transmit.

Received Fax, Manual Dial, 
Error Notification
None No notification. Check the log for 

received faxes or failures. Check Fax 
Terminal for received faxes.

Display icon Displays icon in menu bar so that you 
can check for received faxes and 
transmission problems.

Display icon and alert Same as Display icon, but also 
displays alert box for Manual Dial
and Errors.
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Sending faxes using Fax Sender

Fax Sender is an extension that allows any document or
window that can be printed to be sent as a fax. It handles all
aspects of fax transmission, including forwarding.

Selecting Fax Sender

Selecting Fax Sender is like selecting a local or network
printer, such as an ImageWriter or a LaserWriter.

1 Choose the Chooser from the Apple menu (K).

The Chooser window appears.

2 Scroll down the icons in the upper-left panel, if necessary,
until you see the Fax Sender icon.

3 Click the Fax Sender icon.

The modem icon appears in the panel on the right side of
the window.

4 Close the Chooser by clicking the close box.
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As long as Fax Sender remains selected, all print jobs go to
the fax process, not to your printer. Be sure to reselect the
printer icon in the Chooser when you have finished sending
your fax.

Important As an alternative to the above method of
selecting Fax Sender, hold down the Control and Shift keys
while choosing Print from the File menu. This shortcut does
not deselect your regular printer; you return automatically to
your previous printer settings for printing after the fax is
sent. This shortcut works with all programs.

Fax Sender Page Setup

A number of options are available in the Page Setup 
dialog box.

1 Choose Page Setup from the File menu.

Be sure that you have selected Fax Sender in the Chooser.
Otherwise, use the shortcut of holding down the Control
and Shift keys when you select Page Setup from the File menu.

2 Select Page Setup options as needed, and then click OK.

Refer to Table 2-2 for option settings.
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Table 2-2 Fax Sender Page Setup options

OPTION RESULT

Orientation
Portrait Transmits the fax vertically.

Landscape Transmits the fax horizontally.

Reduce or Enlarge Reduces or enlarges the fax by the 
percentage you indicate.

Image Quality
Fine Converts fax to highest image quality 

for sending. Increases the send time.

Standard Converts fax to normal image quality 
for sending. Decreases the send time.

Bitmap Alignment Scales the Macintosh 72 dpi image so 
that every pixel is matched evenly to 
the fax machine resolution. Produces 
the best quality image for bitmapped 
documents, but enlarges the printed 
image to 108% of actual size.

Entering cover page information

The Cover Page Information dialog box is similar to the Fax
Terminal Info dialog box. Both dialog boxes provide space
for entering return address information to help your
correspondent identify you. In addition, the Cover Page
Information dialog box provides space for the document
subject and a short note.
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1 Choose Print from the File menu.

The Fax Sender dialog box appears instead of the usual Print
dialog box.

2 To fill in cover page information, click the Cover Info button
in the Fax Sender dialog box.

The Cover Page Information dialog box appears.

3 Type information you want to appear on the cover page of
the fax you are sending.

If you have already entered your return address information
in Fax Terminal, you can change the information, the
document name, or add a note. When you change the
information in the Cover Page Information dialog box, it
changes the information entered in the Fax Terminal Info
dialog box, and vice versa.
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The sender name
you see when you
first open the
dialog box is the
Owner Name you
entered for
AppleShare™ in
the Sharing Setup
control panel.



Selecting a cover page

The fax software comes with three cover page choices:

m Standard is a precomposed, text-only cover page. You can
use it as is or modify it with the Fax Cover program. Standard
appears in the Fax Sender Cover Page pop-up menu as the
default selection. (You can also delete the standard cover
page.)

See also: “Installing cover pages” in Chapter 4.

m None means that no cover page is attached to the fax. The
fax is sent as is and no sender or recipient information is
filled in automatically.

m A sample cover page comes with the fax software in the
Fax Folder. This choice does not appear in the Fax Sender
Cover Page pop-up menu unless installed with Fax Cover. 

See also: “Installing cover pages” in Chapter 4.

You can create as many customized cover pages as you need. 

See also: “Customizing cover pages” in Chapter 4 to
compose and modify customized cover pages.

1 Select a cover page from the Fax Sender Cover Page pop-up
menu.

22 Chapter 2

XYZ cover is
a customized
cover page.



Using a telephone credit card

The Telephone Credit Card option allows you to use a credit
card or calling card to send a fax. Using this feature adds
several steps to the sending process. You need to set up Fax
Sender to handle these steps, such as dialing the credit card
access code before dialing the number, detecting the credit
card tone, and entering the card number itself.

Note: If you set Fax Sender to use the credit card option,
all sent or forwarded faxes will use it and the entered card
number. Be sure to disable the option for calls not charged
to a credit card.

1 Type the credit card access code in the Fax Sender Dial
Prefix field.

The credit card access code (0 above) may vary depending
on the card.

2 Click Options in the Fax Sender dialog box.

The Options dialog box appears.
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3 Click the Telephone Credit Card checkbox, and then enter
your credit card number.

Many phone systems send a tone to indicate when the
calling card number and PIN should be entered.

4 To continue setting up your fax, click OK.

Fax Sender protects your privacy by hiding your credit card
number when the Options dialog box is reopened.
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To detect the tone, enter a W in front of the
credit card number. If you find that the tone
is not being properly detected, enter one or
more commas to pause before sending the
calling card number.



Using dial modifiers

Placing a comma in any position in the telephone number,
Dial Prefix box, or Dial Card Number field requests a pause.
This may be useful when dialing long distance or overseas.
To increase the pause time, insert additional commas.

You may need to put additional dial modifiers after the dial
prefix or before the credit card number if your long distance
service acknowledges an access code or telephone number
with a tone before placing the call. See the Dial command in
Appendix A.

DIAL MODIFIER RESULT

Comma (,) Introduces a two-second pause before 
sending the next character.

“At sign” (@) Detects a specified period of silence 
before completing dial string.

Dial tone detect (W) Detects presence of dial tone before 
completing dial string.

Automatic dialing

Auto Dial allows you to use the Fax Phone Book and delayed
send features in Fax Sender. You can use the Fax Phone
Book to make entries for frequently used numbers or to
send a fax to multiple recipients.
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Fax Sender sends your fax to each recipient included in the
Send To field of the Fax Sender dialog box. If there is a
delivery problem for any recipient, Fax Sender puts the fax
to that recipient in the waiting queue for retry (according to
the number of tries you selected in the Retry field in the Fax
Terminal Preferences dialog box). At the same time, Fax
Sender delivers the fax to the other recipients in the order
placed in the Send To field.

Auto Dial is the default selection in Fax Sender. When Auto
Dial is selected, you can transmit your fax from the Fax
Sender or from the Preview dialog box. Auto Dial applies to
most cases. 

See also: “Manual Dialing” later in this chapter.
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Using the Phone Book and Phone Book
Views

Your modem software includes a phone book. It contains
information about each entry such as name, voice telephone
number, fax telephone number, and so on. The phone book
is shared by several programs. Different programs use
different parts of the information in a phone book entry, so
there are different “views” of the information that can be
selected from the phone book pop-up menu. For example, if
you choose the Fax Phone Book view, all entries that contain
a fax telephone number are displayed.

To send faxes using Fax Sender, you can either use the Fax
Quick Send feature, and type in the recipient’s fax number
directly, or select the Fax Phone Book view from the phone
book view pop-up menu and drag recipients’ entries to the
Send To field.

Using Fax Phone Book

Fax Phone Book holds a list of recipients along with their
address and telephone numbers. You can enter, update, and
remove entries from the list and then use the list to address
your faxes by selecting recipients by name. You designate
recipients to receive a fax by dragging their names from 
the Fax Phone Book to the Send To field of the Fax 
Sender dialog.
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Adding entries

You create a list of recipients one by one. You may add them
at send time or whenever you wish.

1 Click New in the Fax Sender dialog box.

A New Entry dialog box appears.

2 Enter the information for the new entry and click Add.

New names are added automatically to the Phone Book
when you click Add.
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These are existing Phone
Book entries.

This entry has been dragged into the
Send To field for sending. A dimmed
entry remains in the Phone Book.

Parentheses and dashes can be
included in the Fax # and
Voice # fields.

You must fill in the Last
Name and Fax # fields.
The other fields are
optional.



Editing entries

To edit an entry

1 Select an entry in Fax Phone Book and click Edit in the Fax
Sender dialog box, or double-click an entry in Fax Phone
Book while holding down the Option key.

2 Change the information by selecting the text and retyping.
Click one of the buttons when you are finished.

m Change saves your edits.

m Cancel restores the old entry.

m Delete removes the entry from Phone Book.

Important There are multiple views of entries that can be
selected from the view pop-up menu, but there is only one
actual phone book. If you change an entry in the Fax Phone
Book view, the changes affect all views of the entry, some of
which may be used by other programs.
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Removing entries

To remove an entry from the Phone Book, select it, then

m Press the Delete key on your keyboard (you are asked to
confirm the deletion), or press x-X. (You must use the
keyboard shortcut for the Cut command.)

To remove recipients from the Send To field

m Drag the recipient outside the scroll box, or double-click the
recipient.

Addressing a fax

You can address a fax to one or to several recipients. Fax
Sender sends the fax to each recipient, one at a time, in the
order placed in the Send To field.

To address a fax

m Double-click the entry in the Phone Book, or drag names
from the Phone Book to the Send To field.
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Dial Prefix

In some cases you may need to place a number sequence,
such as a local area code, before the telephone number. Put
this number in the Dial Prefix field. By placing the prefix
number in the Dial Prefix field, you can keep the numbers in
the Phone Book independent of the dialing prefix.

Setting send time

You can send faxes immediately or at a specified later time.
You change the send time in the Fax Sender Options dialog
for the current fax and in Fax Terminal for any faxes in the
queue. 

Sending immediately

If the Send Immediately button is selected, your fax is sent
immediately. Send Immediately is the default.

Delaying send time (“Send at”)

Fax Sender allows you to set the time for fax transmission.
You may want to delay sending if your recipient is in a
different time zone or to take advantage of lower long
distance toll rate periods.
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1 Click the “Send at” button in the Fax Sender Options dialog
box.

The time displayed is the system time you set in the General
Controls panel or with the Alarm Clock.

2 Click any element in the time or date displays you wish to
change.

An arrow button appears and the element you are changing
is highlighted.

3 Click a directional arrow to set the time.

The time and date you specify must be later than the current
time and date.

You can also change the send time while a fax is waiting to
be sent.

See also: “Resetting the send time” later in this chapter.
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Previewing a fax

Preview is similar to the “print preview” feature of some
programs.

1 If you wish to see your fax before sending, click Preview in
the Fax Sender dialog box.

Scrolling pages

Use the scroll bar at the bottom of the window to view each
page. Clicking the arrow at the right end of the scroll bar
moves through the fax one page at a time beginning with the
cover page.

Changing views

Clicking the View button toggles between reduced and
actual size view of a page. In actual size, you can move the
page with the grabber hand to examine an undisplayed
portion of the page.

Note If you click Cancel while in the Preview dialog box,
you go back to your document, not to the Fax Sender dialog
box. Names that you have dragged to the Send To field are
lost; you will have to select Fax Sender again.

From:

To :

BEMSHA                        09.23.94                       13:01   

Peter Schreier

President

XYZ Company

23 Blaue Gasse

2000 Hamburg 60

49807547                                             49807554

Latest Figures

04/23/94   

Here are the latest cost projections for the next quarter.

2

Fax Phone Number: Voice Phone Number:

Fax Phone Number: Voice Phone Number:

Number of Pages:

Subject:

Notes:

Date:  

Emmanuel Kantu

European Marketing Manager

132 Alvin Road

Aylesbury

Buckinghamshire HP20 2NF England

296395252                                         296395252
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Manual dialing

You can send most faxes using automatic dialing.
Occasionally, you may have to use your telephone to
connect to a recipient’s fax device manually. You may have
to do this if your recipient’s fax machine shares the line with
other devices, if the line is an extension, or if some
intervention by the recipient is required in order to receive.

Note Manual dialing is not available in certain hardware
configurations and in certain countries.

1 Choose Print from the File menu.

2 Click the Manual Dial button.

3 Drag a recipient’s name from the Phone Book to the Send
To field or type a number in the Quick Send field.

4 Click Send.

After Fax Sender has prepared your fax for sending, a
blinking icon notifies you that your fax can now be sent by
dialing manually. 

See also: “Setting Preferences” earlier in this chapter.
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5 When you see the blinking icon at the right end of the menu
bar, select Fax Terminal from the Application menu.

The Manual Dial dialog box appears.

6 Follow the instructions in the Manual Dial dialog box.

m Dial your recipient’s fax number from your handset.

m Click Send when you hear your recipient’s fax tone.
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Table 2-3 Fax Sender options

OPTION RESULT

Dial
Auto Dials recipient’s fax number automatically.
Manual Allows you to dial recipient’s fax number 

manually.

Cover page
Standard Sends fax with text-only cover page.
None Sends fax without cover page.
Custom choices Sends fax with cover page designed in Fax 

Cover.

Phone Book View Select the appropriate view of the phone 
book from the pop-up menu. To send 
faxes, you should always choose Fax 
Phone Book. 

Fax Phone Book To add an address, click New. To edit an 
address, click Edit. To remove an address,
select the address and use the Delete key 
on the keyboard. You are asked to confirm.

Send to Displays the recipient addresses for the 
current fax. To remove an address, drag 
outside the field or double-click.

Preview Allows you to preview your fax before 
sending.
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Fax Sender options (continued)

OPTION RESULT

Cover Info
Sender information Allows you to enter your name, address, 

voice, and fax numbers. 
Subject Prints document name or name you choose 

on cover page.
Notes Prints a short note in cover page Notes field.

Options
Dial:
Tone Selects Touch-Tone dial.
Pulse Selects pulse dial.

Send time:
Send immediately Sends the fax immediately (default).
Delay send (“Send at”) Allows you to choose the time for fax 

transmission.

Telephone Credit Card
Dial Card Number Allows you to automatically append your 

credit card calling number to the 
telephone number. All faxes use this credit 
card number until changed. 
Place dial modifiers before credit card 
number, if necessary.

New Allows you to create a new address and add
it to the Phone Book.

Edit Allows you to edit and delete addresses in 
your Phone Book.
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Receiving a fax

You can receive faxes automatically or manually. The Fax
Terminal application doesn’t have to be open to receive a
fax. Make sure you have your computer correctly set to
receive.

Setting Fax Terminal preferences for
receiving

If you want to receive faxes automatically, you must set Fax
Terminal preferences to allow this or use the shortcut.

1 Choose Preferences from the Fax menu.

2 Click the “Auto-Answer” checkbox in the Preferences dialog
box, then close the dialog box.
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Important If you deselect the Auto-Answer checkbox,
faxes can only be received manually. If you select 
Auto-Answer, faxes can only be received automatically.

Checking for received faxes

Faxes are placed in the Received Fax Documents folder.

According to the choice made in the Fax Terminal
Preferences dialog box, Fax Terminal provides the following
notification for received faxes.

FAX TERMINAL FAX TERMINAL NOTIFICATION
PREFERENCES CHOICE

None No notification. To see if you have 
received a fax, open Fax Terminal and 
look for received fax documents in the 
queue or a blinking arrow in the Status 
box. You can also check Fax Log.

Display icon Fax Terminal displays a blinking icon in 
the menu bar when a fax is received. 
See the following example.

Display icon and alert Same as Display icon, plus also displays
an alert when an error occurs. 
See the following example.
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The following example assumes that Display icon is selected.

1 When you see the blinking icon, choose Fax Terminal from
the Application menu.

The Fax Terminal window appears.

2 Look for the blinking arrow above the icon in the Status box.

Receiving a fax while you’re working

You can receive a fax even if Fax Terminal is not open or in
front. You can also continue working while receiving a fax. If
you set Show Fax Terminal Window in Fax Terminal
Preferences, the Fax Terminal status field indicates the
progress of fax reception.

40 Chapter 2

A blinking
arrow tells you
when a fax has
been received.



Opening a fax document

When you open a fax document in Fax Terminal, the Fax
Viewer program automatically starts.

1 Click a fax document in the Sent Fax Documents or Received
Fax Documents folders.

2 To view your fax document in Fax Viewer, click Open.

The Fax Viewer program opens and your document appears
in a Fax Viewer window. As a shortcut, you can open a fax by
double-clicking it.

See also: “Viewing a fax” in Chapter 3.
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Receiving manually

If you receive primarily voice calls, and only an occasional
fax, it may be more convenient for you to use Manual
Receive instead of Auto-Answer. Manual receive is only
enabled if Auto-Answer is disabled. 

1 Answer the telephone.

2 When your correspondent is ready to send you a fax or when
you hear the fax tone, choose Receive Manually from the 
Fax menu.

A Receive Fax dialog box appears.

3 When you hear the fax tone, click Receive.

When reception is complete, the fax appears in the Fax
Terminal Received Fax Documents folder.
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Monitoring and managing faxes

You can use Fax Terminal to perform a variety of fax
monitoring and management functions, including

m Forwarding faxes

m Checking the status of faxes currently being sent and
received

m Reviewing the list of sent and received faxes

m Canceling the current fax transmission

m Deleting faxes from any of the queue folders

m Resetting the send time for faxes

m Opening and viewing the faxes in your lists

Fax Terminal also contains a log for keeping track of 
fax results.
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Accessing Fax Terminal

Because Fax Terminal is a program that you will use
frequently, it is accessible from the Apple menu (K). To
open it, simply choose Fax Terminal from the Apple 
menu (K).

Viewing Fax Terminal

When you send or receive a fax, Fax Terminal opens
automatically and its name appears in the Application menu
at the right end of the menu bar. Whether you view Fax
Terminal automatically at send or receive time depends on
the choice you made in the Fax Terminal Preferences 
dialog box.

m If you chose “Show Fax Terminal window when sending or
receiving” in the Preferences dialog box:

Choose Fax Terminal from the Application menu to bring
Fax Terminal to the front.

m If you chose not to show the Fax Terminal window:

Select Fax Terminal from the Application menu and then
choose Fax Terminal from the Windows menu to bring Fax
Terminal to the front.

See also: “Setting Preferences” in this chapter.
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Once transmission is complete, Fax Terminal closes
automatically if the fax queue is empty when you change to
another open program.

Important If an alert message appears that says you don’t
have enough memory to open Fax Terminal at send time, you
must quit some of your active programs to provide enough
memory for Fax Terminal to open. You won’t lose any work,
and your fax is still prepared for sending. As soon as you quit
the programs, Fax Terminal opens and your fax is sent.

The Fax Terminal queue contains three types of folders: 
Received Fax Documents, Sent Fax Documents, and Waiting
To Be Sent. See the following table.
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Table 2-4 Fax Terminal document types

ICON DOCUMENT TYPE

Received Fax Documents

Read

These documents have been received and read. They can 
be forwarded.

Unread

These documents have been received but not opened. 
They can be opened and forwarded. See “Opening a fax 
document” later in this chapter.

Sent Fax Documents

Successful

These documents have been successfully sent. They can be 
opened and forwarded.

Unsuccessful

These documents were not sent because of transmission 
problems. They can be opened and forwarded. The 
preferences you selected for the original fax in Fax Terminal 
preferences apply when an unsuccessful fax is forwarded.
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Fax Terminal document types (continued)

ICON DOCUMENT TYPE 

Waiting To Be Sent Documents

Send Immediately (Default)

If you send several faxes in rapid succession, one is sent 
while the others take a place in the queue. You can change 
the order of transmission in the queue by dragging a 
Send Immediately fax up or down to a new position in 
the list.

Delayed Send (“Send at”)

A Delayed Send document’s send time is set in the Fax 
Sender Options dialog box. You cannot drag a Delayed 
Send document to a new position in the queue. See 
“Resetting the send time” later in this chapter.

Retry

A Retry is a fax that has returned to the queue after 
unsuccessful transmission. A Retry takes its next send time 
from the “Time between tries” setting in the Fax Terminal 
Preferences dialog box. You cannot reset the time of a Retry 
fax. A Retry becomes an unsuccessful fax after the number 
of retries expires.

47Getting the Most out of Your Fax Software



Forwarding a fax from Fax Terminal

You can forward any fax you’ve sent or received.

1 Select a fax document in either the Received Fax or Sent Fax
Documents folders.

2 Choose Forward Fax from the File menu.

The Fax Sender dialog box appears. The Send button
changes to Forward.

3 Enter a fax number in the Quick Send field or select an
address from the Phone Book.

See also: “Addressing a fax” in this chapter.
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4 To forward your fax, click Forward.

m Received faxes are forwarded as received with the original
cover page, if one was attached, and your cover page, if you
select one.

m Sent faxes are forwarded without the original cover page, but
you can include one by selecting it when you forward.

m To forward a fax without attaching your cover page, select
None from the Cover Page pop-up menu. 
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Resetting the send time

You can reset the send time of a delayed fax in Fax Terminal.
You cannot drag a delayed fax in front of another fax in the
queue (because you have already assigned it a specific send
date and time in the Fax Sender Options dialog box), but
you can change the assigned send time. See Table 2-4 “Fax
Terminal document types.”

1 To reset the send time of a delayed fax, open the Waiting To
Be Sent folder and select a delayed fax by clicking its name.

2 Choose Set Send Time from the Fax menu.

3 To reset the send time, select the element of the date or
time you want to change.

4 Click the arrow buttons in the Set Send Time box, and then
click OK.
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In this example, the time of the second fax is set ahead so
that it can be sent before the first fax.

Canceling a fax

Canceling stops sending or receiving of the fax in progress.

1 Bring the Fax Terminal window to the front.

2 Choose Cancel Sending or Cancel Receiving from the Fax
menu.

The current fax stops sending or receiving after a few
seconds and Fax Terminal becomes available again. Cancel
Sending does not affect faxes in the queue.
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Deleting a fax

You can delete faxes from the lists inside the folders in the
Fax Terminal queue. You can select several faxes
discontinuously by opening the folders, holding down the
Shift key, and clicking faxes.

1 Open one or more folders.

2 Select one or several faxes to delete.

3 Click the Delete button or press the Backspace or 
Delete key.

Using the Fax Log

The Fax Log keeps information about fax transmissions. This
information may be useful to verify that a fax was actually
sent or received at a given time. The log is especially useful
when you need to check the results of delayed faxes.

Each fax, whether sent or received successfully or not, is
automatically recorded as an entry in the log. When
transmission is finished, you can check transmission results
in the log.
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1 To see the log, choose Fax Log from the Windows menu.

The Fax Log appears and you can scroll up or down.

Managing log entries

For easy log management, you should limit the number of
entries in the log, then archive the log by saving the contents
to a file. For example, you might name the archive files Faxes
Jan, Faxes Feb, and so on for the months of the year.

1 Choose Set Log Entries from the Fax menu and set the
number of entries you wish.

The preset limit for the number of entries in the log is 50. To
avoid losing entries, save the log under a different name as
you approach the limit.

2 To save the log under a new name, choose Save Log As from
the File menu.

3 Type the name you want for the file, then click Save.

Fax Terminal saves the information to a text file, which can
be opened by SimpleText.
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Clearing the log

Once you’ve saved the log as an archive file, you can clear
the old entries from the log.

1 To clear the log, choose Clear Log from the Fax menu.

This clears the entries in the log. Because you have saved the
contents of the log under another name and then cleared
the log itself, no information is lost.

Important It’s up to you to save the log under another
name when you are approaching the limit. If you reach the
limit without saving, the oldest entries are removed
automatically so that the log never contains more than the
chosen number of entries.

To check historical information on the results of a given fax,
you can display any archived logs by opening them with
SimpleText or a word processor. You cannot, however, open
the current Fax Log with SimpleText or a word processor.
You must save it to a file first.
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Table 2-5 Fax Terminal Fax Log

MENU OPTION RESULT

File

Save Log As Saves log under a different name. Archived logs 
can be opened by SimpleText.

Fax
Set Log Entries Specifies the number of entries the log contains. 

Preset value is 50.

Clear Log Clears entries in the log. (You should archive the 
log under a different name before clearing.)

Window
Fax Log Displays Fax Log. Log may be printed 

during display.
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In this chapter

Fax Viewer is a program for viewing and manipulating the fax
documents you receive. This chapter introduces the Fax
Viewer program features, beginning with those you are likely
to use most frequently.

m Opening a fax

m Viewing a fax

m Improving fax display

m Printing a fax

m Editing the pages of a fax

m Selecting part of a fax to paste into a graphics document

m Converting a fax to PICT format

m Forwarding a fax

m Optical Character Recognition (OCR)

Before you begin

You should be familiar with the information in Chapters 1
and 2 on receiving faxes.
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Opening a fax

You can use several methods to open a sent or received fax
for viewing in Fax Viewer.

Open a Fax Viewer document by one of the following
methods:

m Double-click a document in the Sent or Received Fax
Documents folders in the Fax Terminal queue.

m Select a document from the Sent or Received Fax
Documents folders in the Fax Terminal queue, then click
Open.

m Open a Sent or Received Fax document in Fax Viewer using
the Open command in the File menu.

m Double-click a Fax Viewer document in the Finder.

Your fax document appears in a Fax Viewer window.
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Viewing a fax

You can view a fax document at different resolutions by
choosing options in the Page menu:

m Actual Size displays your fax at the real page size (default).

m Fit in Window displays a full page of your fax on your screen.

m Fax Resolution View means that each dot of the 200 dots per
inch (dpi) fax is displayed as a pixel on the Macintosh screen.
The resulting view is approximately 277% of actual size.

Moving around a document

Use the scroll bars to position a page in the window and to
navigate between pages of a fax.

m To examine undisplayed portions of a page, use the vertical
and horizontal page positioning scroll bars at the right of the
Fax Viewer window.

m To scroll pages, use the paging scroll bar at the lower left of
the Fax Viewer window.
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In addition to the paging scroll bar, the Page menu offers
commands for changing pages:

m Previous Page allows you to move backward one page.

m Next Page allows you to move forward one page.

m Go To Page displays a dialog box for moving to a 
specific page.

Changing the page orientation

The options in the Page menu allow you to view your fax in
the orientation you prefer.

Choose the orientation you wish from the Page menu:

m Rotate Right turns the current fax page 90 degrees
clockwise.

m Rotate Left turns the current fax page 90 degrees
counterclockwise.

m Flip Vertical rotates the current fax page 180 degrees.

m Flip All Pages rotates all the pages in the current fax 
180 degrees.
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Improving fax display

Fax Viewer has a special smoothing feature that allows you
to optimize fax display. Smoothing increases the sharpness
of a fax on your screen, permitting easier reading and
scanning with OCR software.

1 Set your monitor to 256 Colors or Grays, if available, in the
Monitors control panel.

Depending on the content of the received fax, you can
experiment with the monitor settings and the Use
Smoothing command to get the best resolution for display.
Smoothing is enabled by default.

2 Choose Use Smoothing from the Page menu.
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How smoothing works

The resolution of a fax is 200 dots per inch (dpi). Your
Macintosh converts the 200 dpi fax resolution to the 72 dpi
of the Macintosh screen. The conversion process
concentrates gray areas together, making the document
appear darker. The smoothing feature looks for dark areas,
then applies a special algorithm known as dithering to
improve document resolution.

Printing a fax

You print a fax the same way you print any document. See
“Print a Document” and “Printing Your Work” in your
Macintosh user’s guide. Make sure the printer is selected in
the Chooser.

Editing a fax

You may need to resequence, eliminate some pages, or
combine pages from several faxes. Editing in Fax Viewer is
similar to editing in other applications such as paint
programs. Generally, edit operations in Fax Viewer affect an
entire page. The page is the basic unit in a Fax Viewer
document. Because a fax is a graphic image, it is similar to
documents created in a paint program. This means that you
cannot edit the text as you can in a word processor.
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Copying, cutting, or clearing a page

Entire pages can be copied or cut to the Clipboard for later
use, or cleared from the document.

1 Make sure you’re viewing the page you wish to cut.

2 Choose Copy Page, Cut Page, or Clear Page from the 
Edit menu.

Copy Page copies the current page to the Clipboard. Cut
Page cuts the current page, puts it on the Clipboard, and
decreases the page count by one. Clear Page clears the
current page and decreases the page count by one. If you
make a mistake, choose Undo from the Edit menu.

The Clipboard holds one page at a time. Be sure to paste the
page into a Fax Viewer or paint program document before
copying or cutting another page.

Pasting a page

You may paste a cut or copied fax page into any Fax Viewer
or paint program document.

1 Select the page you want and cut or copy it to the Clipboard.

2 Use the Scroll Bar to display the page that will precede the
page you want to paste in.

3 Choose Paste Page from the Edit menu.

Notice that the page count increases by one page and that
Fax Viewer places the page after the one displayed.
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Selecting a portion of a page

Paste operations in Fax Viewer only operate on entire pages.
However, you can select a portion of a page for pasting into
a document created by another graphics program. Fax
Viewer provides a selection rectangle tool for selecting and
copying portions of documents.

1 Select the page you wish to copy from.

2 Move the pointer over the page.

Notice that the arrow pointer becomes a crosshair. It now
functions as a selection rectangle tool for selecting
rectangular areas.

3 Drag the selection rectangle tool across the image from the
upper left to the lower right, releasing the trackball or
mouse button when the image is enclosed.

A moving dashed line encloses the selected image.

4 Choose Copy Selection from the Edit menu.

Fax Viewer places the selected image at current resolution in
PICT format in the Clipboard.
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5 Make your paint program document the active window, then
choose Paste from the File menu.

The selected image appears in your document.

Converting a fax to a PICT file

Fax Viewer allows you to save in Fax Viewer or in PICT file
format. Fax Viewer documents can be opened only by the
Fax Viewer program. PICT files may be opened by many
graphics programs. In other words, the Save As command
acts as a conversion tool for fax documents.

1 Choose Save As from the File menu.

The Save As dialog box appears. Notice the pop-up menu,
titled Format at the bottom of the dialog box.

2 Change the document type using the Format pop-up menu.

In the following example, Fax Viewer is checked because the
document is a Fax Viewer document. Dragging to PICT
selects PICT format.

3 Rename the document if you wish, then click Save.

The current page is converted to PICT format (72 dpi) and
saved.
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CONVERSION FILE FORMATS USE

Fax Viewer Can be opened only by Fax Viewer

PICT 72 dpi Standard PICT format

PICT 200 dpi High definition PICT format

Forwarding a fax from Fax Viewer

Fax Viewer forwards your faxes in the same way Fax Terminal
does.

1 Open a Fax Viewer document using any of the several
methods, then choose Forward Fax from the File menu.

See also: “Opening a fax” earlier in this chapter.

The Fax Sender dialog box appears.

2 Forward your fax as you would in Fax Terminal.

See also: “Forwarding a fax” in Chapter 5.
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Optical Character Recognition (OCR)

A fax is transmitted as graphic information. A received fax
document cannot be opened with a word processor or
edited as text. The Fax Viewer OCR feature allows you to
scan a fax and convert its graphic pixels to text. You can
convert part of or an entire document to text.

OCR converts only printed characters in a fax document to
text format. Character recognition is not the same as
handwriting recognition; OCR cannot recognize and convert
handwriting into text.

OCR Dictionaries

When you install the Fax software, the Installer places some
items related to OCR in a Mimetics folder in your System
Folder. Some of these items are language-specific
dictionaries needed to recognize the words in the document
target language. Dictionaries exist in several languages. You
may obtain dictionaries for other languages by writing to the
address on page ii (copyright page) of this booklet. To install
other dictionaries, simply drag them into the Mimetics
folder.
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OCR tips

You can increase the chances of successful character
recognition by taking the following precautions. Ask the
originating fax to

m send documents in High Resolution Mode—200 dpi,
sometimes called Fine resolution

m use characters between 10 and 30 points in size. After 30
points the OCR interprets the characters as graphics

m use outline fonts or TrueType fonts instead of bitmapped
fonts

m insert the document at a right angle (vertically or
horizontally). It must have no more than a 7% slant

OCR works with Fax Viewer documents only.

Setting up OCR

When the OCR software scans your document, it may not be
able to recognize all the characters. OCR preferences allows
you to prepare for such eventualities.

1 Choose OCR Preferences from the Fax Viewer Page menu.
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2 In the dictionary pop-up menu, choose the dictionary that
corresponds to the document language.

3 Click the “Ask for ambiguities” checkbox if you want OCR to
ask you to resolve any character recognition problems.

OCR can be confused by similarities between characters and
you may need to choose the correct character in a dialog box
at the end of the recognition process.

4 Type a character to replace any ambiguous characters, then
click OK.

The character (#) is proposed by default.

5 For now, leave the memory set to 2000K.

It may be necessary to change later.

Important If an insufficient memory message appears:

m Immediately after running OCR You will need to
increase the amount of RAM in your Macintosh or use
virtual memory. See your Macintosh Reference to
accomplish this.

m During the scanning process Choose OCR
Preferences from the Fax Viewer Page menu and increase
memory size to 2400K, for example.
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Working with OCR

The OCR process works page by page, performing the
following steps:

m Preparing data OCR finds pictures and removes them.

m Analysing page OCR locates the columns of text.

m Processing page OCR searches the target language
dictionary for the word closest to the recognized pattern and
places it in text format in the clipboard or in a new
document.

Converting part of a document to text

1 Open a Fax Viewer document and select some text with the
selection rectangle tool.

2 Choose Copy Selection as Text from the Edit menu.

OCR scans the selected text, then places the results in the
Clipboard in text format. You can paste the text into
SimpleText or any word processor program. If you selected
Ask for ambiguities, any questionable characters are selected
and you can type the correct character in the following
dialog box.
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OCR has enclosed the character A and is asking you to
resolve the problem.

3 Type ‘A’ in the recognized shape field, then click Accept.

You can skip over characters you don’t want to change by
clicking Ignore or Ignore All for the current page.

4 Choose Show Clipboard from the Edit menu.

The text is displayed and you can paste it into another
program.

Converting a page of a document to text

1 Open a Fax Viewer document and use the page scrolling bar
to go to the page you want to convert to text.

2 Choose Copy Page as Text from the Edit menu.

The text is stored in the Clipboard and you can paste it into
another program.
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Converting a whole document to text

1 Open a Fax Viewer document.

2 Choose Save As from the File menu, then select Text only in
the Format pop-up menu.

3 Rename the document or accept the file extension ‘(Text)’
that Fax Viewer appends to the default file name.

Fax Viewer saves your text in SimpleText format. You can
open it with a word processor.

Printing faxes with FastPrint™

The Fax Viewer includes a FastPrint feature for printing fax
documents more quickly on PostScript printers. The speed
of printing can be significantly improved, but is only available
if the preferred memory size setting of the Fax Viewer
application is set to at least 1500K (the default is 290K). 

To enable FastPrint

1 Select the FastPrint checkbox in the Fax Viewer print dialog
box. 

Important  FastPrint only works with PostScript printers.
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In this chapter

Fax Cover allows you to create, manage, and save fax cover
pages. You don’t have to attach a cover page to a fax before
sending. If you want to use customized cover pages with
your faxes, you must read this chapter.

m Customize the fields on a cover page

m Align fields

m Add graphics to a cover page

m Install and remove cover pages
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Customizing cover pages

Cover pages contain fields for address information. Each
field has a title and contains text. Field titles are labels, such
as “To” and “From.” Field text is information you enter, such
as your recipient’s name. You customize a cover page by
rearranging the appearance and positions of the individual
fields and by adding graphics.

Customizing  fields

You can decide which fields to display, change title names,
edit field title and field text appearance, and position and
resize fields on the cover page.
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1 Open the Fax Cover folder (installed on your hard disk) and
double-click the Fax Cover icon.

When a new cover page appears, it displays fields of titles
and text. You can identify field text by the angle brackets
(< >) surrounding it. Text in angle brackets acts as a
placeholder for the text you enter in the Cover Page
Information dialog box and Phone Book in Fax Sender.

2 Choose Show Fields from the Layout menu.

All fields are selected by default. The Show Fields command
displays a dialog box for specifying which fields will be
shown on the cover page. Clicking a field deselects it
(removes the checkmark), and it will not appear on 
the page.
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3 Position the cursor on a field title to edit the field title name.

Clicking a field title automatically selects the entire title.
Field titles are editable text. You can edit them as you would
any text, as well as change the font, size, and style using the
menus. To edit multiple field titles at once, you can use
Select All Field Titles from the Edit menu, or you can 
Shift-click to select combinations of fields to edit at one time.

4 To change the font, size, or style of the field text, click
anywhere in the text area to highlight the field text and use
the Font, Size, and Style menus.

You can use Select All Field Text from the Edit menu, or you
can Shift-click to select combinations of fields to edit at 
one time. 

If you choose a font, size, or style for the field that would
require vertical space greater than the current size of the
field, the field automatically increases to the required height.

Note: You can change the font size or style of the Field
Text, but you cannot edit the text itself. You can only edit
the text of Field Titles.
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Positioning and resizing fields

You can position and resize fields individually or in groups.

1 To select a field, click anywhere in the field text, not on the
field title.

Clicking inside the field will highlight the text within the
field, and handles will appear at the field corners.

2 To resize the field, drag one of the handles.

3 To reposition a field, drag the field by its center (not by a
handle) to a new location on the page.

When a field is moved, the field title moves with the field.
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Using the grid and aligning fields

The grid allows you to align fields easily as you move them.
When the grid is turned on, fields that you move or resize
will automatically snap to the nearest grid line whether
visible or not.

1 To turn the grid on, choose Turn Grid On from the 
Layout menu.

2 To see the invisible grid lines, choose Show Grid Lines from
the Layout menu. 

You can align fields to the grid or to each other.

3 Select the fields you want to align by shift-clicking.

You might choose fields at random in the following
positions.
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4 Choose Set Alignment in the Layout menu.

The following dialog box appears.

5 Choose Align Objects To Grid and set the grid spacing, or
choose Align Objects To Each other.

6 Choose the Vertical and Horizontal alignment options you
want.

7 Click OK.

Note: To reuse the same alignment settings, just choose
Align from the Layout menu. The settings stay the same until
you change them.

Adding graphics

You can import previously created PICT graphics to a cover
page and resize and combine them with text. You can use
the clipboard or the Import PICT command in the Fax Cover
File menu to import a PICT file.

Important Only PICT files can be imported to cover pages.
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1 To reposition the graphic, just drag it to a new location on
the page.

You can resize an imported graphic by dragging the handles,
and you can move it to an empty space on the cover page or
place it in the background behind superimposed text fields.

From :

Fax Phone Number :

To :

Voice Phone Number :

Voice Phone Number :Fax Phone Number :

Subject :




Number of Pages : Date :

Notes :










<Sender Name>

<Title>

<Company>

<Address Line 1>

<Address Line 2>

<Address Line 3>

<Recipient Name>

<Title>

<Company>

<Address Line 1>

<Address Line 2>

<Address Line 3>

          <Recipient Fax Number>                                    <Recipient Voice Number>

<Notes>

            <Number of Pages>                                                      <Date/Time>

<Subject>

            <Sender Fax Number>                                         <Sender Voice Number> 
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You will be able to see your completed fax with the cover
page at send time by selecting Preview in the Fax Sender
Print dialog box.

The sample cover page below was prepared with TrueType
fonts. Installing TrueType fonts will allow you to send fax
text—even in large character sizes—with excellent character
definition.

From:

To :

BEMSHA                         09.23.94                       13:01   

Fax Phone Number: Voice Phone Number:

Fax Phone Number: Voice Phone Number:

Number of Pages:

Subject:

Notes:

Date:  

Peter Schreier

President

XYZ Company

23 Blaue Gasse

2000 Hamburg 60

632950                                                632351

Latest Figures

 04/23/94   

Here are the latest cost projections for the next quarter.

2

Emmanuel Kantu

European Marketing Manager

132 Alvin Road

Aylesbury

Buckinghamshire HP20 2NF England

296395252                                          296395252
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Installing cover pages

A new custom cover page must be saved and then installed
in the Fax Sender cover page library. You install it only once.
When you edit an existing cover page, the changes are saved
without reinstalling.

1 Save your customized cover page.

2 With your cover page open, choose Install Cover Page from
the File menu.

The current cover page is installed in the Fax Sender cover
page library under the name you selected, in this case, “XYZ
logo cover.” You will be able to choose it from the Fax
Sender pop-up menu at send time.

Note: To modify an installed cover page, open the cover
page, modify it, and then save it. The cover page remains
installed.
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Removing a cover page

1 Choose Remove Cover Page from the File menu.

A dialog box appears with a list of all currently installed cover
pages.

2 Select the cover page you want to remove.

You can remove multiple cover pages by Shift-clicking their
names to select them.

3 Click Remove.

Important Once removed, a cover page will no longer be
available in the Cover Page pop-up menu in the Fax Sender
Print dialog box. It still exists as a Fax Cover document,
however, and you can open, edit, and reinstall it later.
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Table 4-1  Summary of Fax Cover menu options

MENU OPTION ACTION

File
Import PICT Allows you to import a PICT file into a 

cover page.

Install Cover Page Puts a cover page in a library of cover pages. 
Cover pages are available from Fax Sender 
Cover Page pop-up menu.

Remove Cover Page Removes an existing cover page from cover 
page library. Removed cover pages can be 
reinstalled.

Edit
Select All Field Titles Selects all field titles in an open cover 

page document.

Select All Field Text Selects all field text in an open cover 
page document.

View
Actual Size Sizes to real cover page size.

Fit in Window Sizes to current window size.

Reduce Offers 25%, 50%, 75%, and 100% views.

Enlarge Offers 25%, 50%, 75%, and 100% views.
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Summary of Fax Cover menu options (continued)

MENU OPTION ACTION

Layout
Show fields Allows you to choose the fields for cover 

page display.

Turn Grid on Activates and deactivates grid.

Show Grid Lines Makes grid visible.

Align Aligns selected fields according to Set 
Alignment dialog settings.

Set Alignment Allows you to set alignment parameters.

Use Default Size Restores selected PICT to original size.

Font Allows you to set font type and size for text.

Style Allows you to set style and alignment 
for text.

Windows Shows names of open cover pages. Allows 
you to bring any open document to 
the front.
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In this chapter

This chapter informs you about

m Fax Sender GX and QuickDraw GX

m Choosing Fax Sender GX

m Fax Sender GX Page Setup

m Sending a fax

m Drag-and-drop fax send

m Using Fax Sender GX as a fax server on an 
AppleTalk™ network
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Before you begin

To use Fax Sender GX to send faxes, you must have
QuickDraw GX version 1.1 or greater installed as part of your
system software. You should also be familiar with printing
from an application in the QuickDraw GX environment. 

See the documentation that came with your Macintosh for
more information. You should understand the basic
operation of sending a fax, as described in Chapter 1, “Fax
Software Quick Start.”
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Fax Sender GX and QuickDraw GX

QuickDraw GX imaging software is part of System 7.5.
Features and advantages of QuickDraw GX include
enhancement and simplification of the printing process.
Since sending a fax using the fax software is just like printing
to a remote printer, you can take advantage of many of these
features using Fax Sender GX. The following pages introduce
you to these features and lead you through the steps of
sending a fax using Fax Sender GX.

Important When you install the fax software, the software
necessary to use Fax Sender GX is also installed. If you
already have QuickDraw GX installed as part of your system,
you see Fax Sender GX in the Chooser. If you don’t have
QuickDraw GX installed, you see Fax Sender in the Chooser.

Sending a fax

Sending a document as a fax using Fax Sender GX is pretty
much like printing the document. You go through the same
steps of choosing and setting up the output device before
you print. Additionally, you must provide information about
your recipient or recipients, just as you do when using 
Fax Sender.
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Choosing Fax Sender GX

1 Select Chooser from the Apple menu (K).

The Chooser dialog appears.

2 Scroll, if necessary, in the upper left panel until Fax Sender
GX is visible.

3 Click the Fax Sender GX icon to select it.

4 Click the Create button in the lower right corner.

This creates a desktop printer icon for Fax Sender GX. Using
desktop printer icons for drag-and-drop printing is discussed
later in this chapter.

5 Click the close box in the upper left corner to close 
the Chooser.

Documents printed by applications will now be sent as faxes
by Fax Sender GX.
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Fax Sender GX Page Setup

Before sending your document, you need to select the
appropriate Page Setup options.

1 Select Page Setup from the File menu.

The Fax Sender GX Page Setup dialog appears.

2 To see more options, click More Choices.

3 Select the Paper Type, Orientation, and Scale settings you
want. Be sure that Fax Sender GX is selected in the “Format
for” pop-up menu.

4 Click Format.
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Print dialog options

Now you are ready to send your fax. Remember that sending
a document as a fax is just like printing to a remote printer.

1 Select Print from the file menu.

The Fax Sender GX print dialog appears.

2 To see more options, click More Choices.

3 Select the General print icon in the upper left corner if it is
not already selected.

4 Be sure that Fax Sender GX is selected in the “Print to” pop-
up menu.
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5 Select the fax quality (Fine, Standard, or Bitmap Alignment)
you want from the Quality pop-up menu.

See also: “Fax Sender Page Setup” in Chapter 2 for an
explanation of the quality settings.

6 Click Fax.

When you set the print dialog general options and click Fax,
you send your document to Fax Sender GX to be imaged
and transmitted. You still need to set the transmission
options, such as the recipient’s fax number 
and cover information.

Addressing your fax

When you click Fax in the system print dialog, the regular
Fax Sender print dialog appears. The information you have
filled in can be changed or left as is. Now you choose
recipients, fill in cover information, and select transmission
time, just as in the existing Fax Sender software.

See also: Chapter 2 if you need to review the options and
steps for addressing a fax.

7 Once you have addressed your fax, Click Send.

If you have selected Send Immediately (the default setting)
in the Fax Sender Options dialog, your document is imaged
and your modem dials and transmits your fax.
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Print time and send time

QuickDraw GX allows you to set the print time (by selecting
the Print Time panel in the Print dialog).

The time you set is the time at which your document is
passed to Fax Sender GX for processing. The send time that
you set in the Fax Sender Options dialog is the time at which
the modem dials your recipient’s fax number and transmits
your fax over the phone line.

Important If you want to send your fax at a specified time,
you should set the time in the Fax Sender Options dialog
rather than in the Print dialog. In this case, just leave Print
Now set in the Print Time panel of the print dialog.

Drag-and-drop fax send

One of the most powerful features of QuickDraw GX is 
drag-and-drop printing. You create a desktop printer icon for
a printing device, then simply drag documents and drop
them onto the icon for printing. You can send faxes the
same way using Fax Sender GX.
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If you followed the steps at the beginning of this chapter,
you have already created a desktop printer icon for Fax
Sender GX. Once you have created a desktop printer icon
for Fax Sender GX, you can simply drag a document and
drop it onto the Fax Sender GX icon to send the document
as a fax.

Sending a fax is just like printing, except that when you use
drag-and-drop to send a fax there is one additional 
step—addressing your fax. When you drop a document onto
the Fax Sender GX desktop printer icon, the Fax Sender
dialog appears, so that you can choose your recipient or
recipients just as you would ordinarily.

Using Fax Sender GX on an AppleTalk
network

Using Fax Sender GX, you can set up one machine on an
AppleTalk network to be a central server for sending faxes.
Other users on the network can then send faxes without
having the modem hardware installed in their computers.

In order to do this, the server must have the appropriate
hardware installed. Both the server and client machines
must have the fax software installed.

Sharing a fax server

Once you have created a desktop printer icon for Fax Sender
GX on the server, you can share access to it across the
AppleTalk network just as you might share a hard disk or
CD-ROM drive. See your Macintosh documentation for
details on the sharing process.

If you are sharing your modem on an AppleTalk network, try
to minimize the time you spend in fax preview. While you
are previewing, remote Fax Sender GX users are paused.
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Sending a fax from a network client

Once a fax send server has been created and shared on your
AppleTalk network, other users on the network can access it
as a client, provided that they have the necessary access
privileges. 

Important each client must have the fax software installed.
To install the fax software on a client machine, select the
“Fax Sender GX Client Software” Custom Install option in
the Installer.

When these conditions are met, sending a fax as a network
client is no different from sending a fax from your local
Macintosh. The only exception is that you must select
Servers in the “Connect via” pop-up menu in the 
Chooser dialog.

Important When a transmission problem occurs, the error
is reported on the server, that is the Macintosh that has the
modem hardware installed. Therefore, if you send faxes as a
network client, you should check the fax log of the server
frequently to verify that your faxes have been sent correctly.
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In this chapter

This chapter provides information about

m configuring Apple Fax Gateway

m adding fax services to your Key Chain

m configuring fax services

m using Apple Fax Gateway

m problem alerts
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Welcome to Apple Fax Gateway 

Apple Fax Gateway adds fax services to PowerTalk when
used with the appropriate modem hardware. Once you have
installed and configured the software and hardware, you can
send documents to fax recipients, along with other e-mail
recipients, from programs that support the PowerTalk
Mailer. You can also send faxes from the desktop by
dropping TEXT or PICT documents onto PowerTalk
information cards that contain fax addresses. Most
importantly, your received faxes are presented in the
PowerTalk Universal Mailbox along with the rest of your
electronic correspondence. Received faxes appear in your 
In Tray and can be opened, viewed, edited, and printed
using the Fax Viewer program that is included as part 
of the software.

PowerTalk 1.1 or later must be installed in your system
before you can take advantage of  the Apple Fax Gateway
features. PowerTalk 1.1 is included with System 7.5.
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Configuring Apple Fax Gateway

Adding fax services to your Key Chain

Before you can send and receive faxes, you must add fax
services to your Key Chain.

1 Select Key Chain from the Mail and Catalogs sub-menu in the
Apple Menu ().

The Key Chain dialog appears.

2 Click Add.

3 Select Fax Terminal if it is not already selected, then
click OK.
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You return to the Key Chain dialog. Fax services have been
added, but they are not yet configured.

Configuring fax services

To configure fax services

1 Double-click Fax Terminal in the Key Chain dialog, or select
it, then click Open.

The Fax Terminal configuration dialog appears.

All of the features in the dialog, as well as those that are
accessed by the Options, Preferences, and Fax Terminal Info
buttons, work just like their counterparts in the Fax Terminal
program included in your fax software package. 

See also: Chapter 2, “Getting the Most out of Your Fax
Software” for complete detail about these features and
options. 
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Using Apple Fax Gateway

Sending fax documents

You can send documents from any application that supports
the PowerTalk Mailer by including one or more fax addresses
as recipients. Fax addresses can be selected from catalog
entries or can be typed in using the PowerTalk Mailer’s 
Type-In addressing feature. The subject that you specify in
the Mailer appears on the fax cover sheet, if you checked
“Add Standard Cover Page” when setting up the fax gateway
software.

In addition, enclosures of type TEXT or PICT can also be
sent as faxes. Note that you cannot send other types of
information, such as sounds, as faxes. To send fax
documents from other programs that support the PowerTalk
Mailer, be sure to choose either AppleMail or Snapshot
format. Refer to the documentation that comes with your
program for more information.

If you are using System 7.5, see the step-by-step help in the
AppleMail Guide and PowerTalk Guide in the Guide menu
for detailed instructions on using the mailer and information
cards.

Another way to send TEXT, PICT, or AppleMail documents is
to drag the document onto an information card, if you have
designated the fax address as the “preferred” electronic
address. Adding fax addresses is explained in the following
discussion.
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Adding fax addresses to your PowerTalk
information cards

To add a fax address to PowerTalk information card

1 Open an information card and select Electronic Addresses
from the pop-up menu. (If you want to create a new
information card, open your personal catalog, select New
User from the Catalog menu, and type in the name for 
the card.)

2 Click Add.

3 Select Fax Terminal, then click OK.

A new, untitled fax address is added.

4 Select the untitled user name and type whatever name you
wish for your recipient.
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5 Select the user, then click open, or double-click the user
name.

6 Click in the Fax Number field and enter the user’s fax
number, then click the close box to close the fax number
window.

7 If you leave “Preferred” selected, the fax address is the
preferred electronic address. Whenever you select this user
in the addressing panel or drag a document onto the user’s
information card, the fax address is used.
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Receiving fax documents

You can receive faxes from any fax machine or fax modem.
When you receive a fax, it appears in your In Tray just like
any other incoming mail.

Opening received fax documents

To open a received fax from your In Tray

1 Double-click the document.

The document is opened with the Fax Viewer program. You
can view, edit, and print it using the Fax Viewer program. 

See also: Chapter 3, “Fax Viewer” for complete information
about Fax Viewer features.

104 Chapter 6



Problem alerts

If an error occurs while sending or receiving a fax, you will
get a problem alert in your Out Tray or In Tray.

To see and resolve a problem alert

1 Click the Problem Alert icon in your In Tray or Out Tray.

The Problem Alert appears with an explanation of the
problem.

2 Click Resolve to remove the alert, or simply close the
window to leave it unresolved.

Several of these Problem Alerts are described below

m “Some of the enclosure file(s) have been ignored. Only
TEXT and PICT files can be converted to the fax format.” 

You get this message if you enclose another type of file in an
AppleMail document to be sent as a fax. Only files of type
TEXT and PICT can be enclosed. Most word processors,
paint, and draw programs have options to save their
documents in one of these formats.
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m “The generated fax document is empty and will not be sent.” 

You get this message if all of your enclosures are of the
wrong type (neither TEXT and PICT), and your document
itself is empty, or if you drag a document of the wrong type
onto an information card that has fax as its preferred
electronic address.

m “The System Extension ‘Fax Extension’ is not present in the
System Folder.” 

Apple Fax Gateway requires that the Fax Extension be in the
Extensions folder within the System Folder in order to work.
It is placed there by the Installer program when you install
the fax software. If the file subsequently gets moved,
deleted, or damaged, you will need to reinstall it.
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In this chapter

This chapter provides information about

m automatic dialing

m address book

m outgoing call log

m voice mail

m AppleTel Preferences
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Welcome to AppleTel

AppleTel is a telephony program for your Macintosh. It
brings automatic dialing and voice mail functionalities to
your computer. When used in conjunction with the fax
software, AppleTel helps you centralize all of your telephony
and communications needs on your computer and to
integrate them with your other activities more completely
than you could by using separate devices such as fax
machines, answering machines and conventional data
modems.

Note AppleTel is not included in certain configurations in
certain countries. If AppleTel is not included in your package
you don’t need the information in this chapter.
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Automatic dialing

AppleTel brings screen-based telephony to your Macintosh.
You can store frequently used phone numbers in the
Address Book and dial automatically, or dial manually by
clicking or typing. AppleTel keeps a log of all outgoing calls.
You can connect a telephone to the same line (if permitted
in your country).

Calling out

To place a call to a recipient for whom you already have an
entry in your Address Book

1 Open AppleTel.

The Phone dialer appears.

2 Click Address Book.

The Address Book appears.
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To dial a number not in the address
book, type the number in this field
or click the numbers on the dial pad
to the left, then click Dial or press
Return or Enter.



3 Scroll down to the name of the person you want to call and
select it, or if the Address Book is lengthy, type the first
three letters of the name.

4 Click Dial in the Address Book.

5 Pick up your handset after dialing is completed.

The dialer may be also used for telephone features like Call
Waiting and Call Transfer. The R button is equivalent to the
flash hook function found on some phone handsets, that is,
momentarily pressing the receiver.

Address Book

The Address Book stores names and phone numbers 
for dialing.

AppleTel and the fax software share the same Address Book. 

See also: Chapter 2, “Using the Phone Book and Phone
Book Views” and “Using Fax Phone Book” for detailed
information on adding, editing, and deleting entries in the
Address Book.

Important Since the address book is shared, if you modify
or delete entries in one program, the changes will be
reflected in all other programs.
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Address Book Import/Export

You can use the Import/Export options in the File menu to
import to or export from the AppleTel Address Book. If you
already have an address book created by another program,
and personal information manager or database, for example,
you may be able to save it in a text format that can be
imported by AppleTel. 

To do so, you’ll need to understand both the formatting
options of the other program and the AppleTel format. The
AppleTel format is described in the following paragraphs. 

See also: the documentation that came with the program
that originally created your address book for information on
its formatting options.

The AppleTel Address Book format is text. Each entry is
stored as a record consisting of separate fields for name,
phone numbers, and so on. Within a record, the fields are
separated by field delimiters. Within the file, the records are
separated by record delimiters. The record layout is
described below:

m ‘AppleTel’ followed by carriage return <CR> must appear
as a file header. 

m Each field must be followed by a field delimiter character, a
tab<→> by default. 

This character can be changed in the Import/Export options
menu. 

m Each record must end with a <CR>. 

m The fields in correct order are: Last name, First name,
Address, Voice, Fax, Comment. 
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A sample file containing two records is shown below:

‘AppleTel’<CR>

Smith<→>John<→>2124 Floral Ave. Queen City, NC
28999<→>555-7474<→>555-7574<→>John Smith is
my mother’s boss.<CR>

Jones<→>Jerry>5434 Michigan Ave. Queen City, NC
28919<→>555-1245<→>555-3467<→>Jerry Jones is
Juanita’s oboe teacher.<CR>

Log

Call logging allows you to have a record of outgoing calls.
This can be useful to you for many reasons, for example,
having a record of calls you place could help with client
billing or expense tracking. You can set up and sort the call
log in a variety of ways.

1 To consult the Log, choose Show Log in the Windows menu.

The Log appears and you can sort it according to your
preference by clicking on Name, Number, or Date. The
heading currently in use as a sort criterion is underlined.

2 To set the number of Log entries, choose Log options in the
Edit menu. If you select “Record all outgoing calls”, then the
log is limited only by disk space. Otherwise, when the
number of calls in the log reaches the number you choose,
the oldest log entries are deleted as new entries come in.
This avoids having the log take up too much disk space. If
you wish, you can archive the log to a file.
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3 To archive the Log, choose Save Log As in the File menu.
Choose an appropriate name and location for the archive file
and click Save.

The log is saved, so as new calls are logged and older entries
are deleted, you won’t lose any information.

Voice Mail

AppleTel can be used as either a basic answering machine, or
as a sophisticated voice mail system, depending on your
needs. It allows you to configure and use your computer as a
voice message center. Basic answering machine functionality
allows you to record an outgoing message (greeting) and to
record, play, and manage incoming messages. All callers get
the same greeting and leave messages in the general
mailbox. For many users, this is enough. 

If you need more complete voice mail functionality, you can
use advanced options like private mailboxes, secondary
greetings, and interaction with the caller. When you use
private mailboxes, you can get input from callers using
Touch-Tone phones and, based on their input, play
additional greetings and record their messages to 
separate areas.

You can manage up to ten voice mailboxes (one general
mailbox and nine private mailboxes) for recording messages
and remote message retrieval. Remote message retrieval
allows you to call your voice mail system from any phone
and retrieve your messages. 

Each of the mailboxes may be password protected; a
password is mandatory for remote message retrieval,
ensuring that only you can retrieve your messages. Messages
are recorded onto your hard disk.
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Setting the volume

The volume slider in the voice mail window controls the
volume for message playback and for monitoring while
messages are being recorded from the phone line. If you
don’t want incoming messages to be heard during recording,
set the volume slider to its lowest setting. This does not
affect the volume at which messages are recorded.

Recording a greeting

Before using AppleTel’s voice mail capabilities, you will want
to record a greeting (outgoing message) that your callers will
hear when their calls are answered. To be effective, your
greeting should be free of background noise, intelligible,
continuous, clearly enunciated, and suitable to the purpose
for which it is intended. Your greeting should begin within
three seconds of answering, so try not to leave a gap of
silence at the begining when you record your greeting. It is
helpful to your callers if you include your telephone number
in your greeting so that they are sure they have reached the
correct number.

To record a General greeting

1 Select the General folder in the Voice Mail window, then
click Greeting.

The recording dialog box appears.
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2 Click the Record button.

3 In a clear, audible voice, speak into the microphone on your
modem, if you have an external modem, or the built-in or
external microphone of your computer if you have an
internal modem from a distance of about 40 centimeters. 

When your greeting is finished, click Stop.

4 To replay your greeting, click Play.

5 If you are satisfied with the greeting, click Save.

If you are not satisfied, repeat the above procedure.

Replaying a greeting

To replay the greeting

1 Open the General folder.

The folder contents appear (for the moment, only the
greeting you just recorded is present).

2 To replay greeting, select it, then click Play (or type Return
or Enter).
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Waiting for incoming calls

Voice Mail can be turned on and off.

1 Choose Preferences from the Edit menu.

2 Select Voice Mail settings in the dialog box according to the
following table.

ACTION RESULT

Click Auto-Answer Turns Voice Mail on.

Set number of rings Determines number of rings for 
using the arrows auto-answer. May not be changed in

some countries.

Click Show Voice Mail Opens the Voice Mail window 
automatically when  message is 
received.

Type the value in the field Sets the maximum duration of an 
incoming message (in seconds).

All of the options in the Preferences dialog are explained
later in this document.

Retrieving messages

When a message is received, the AppleTel icon blinks in the
upper right corner of the menu bar. If you selected Show
Voice Mail window in Preferences, AppleTel will open when
a message is received.

1 To retrieve a message, open AppleTel, if necessary.

2 If open, choose Voice Mail in the Windows menu, if
necessary.

3 Double-click the General folder.
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Listening to messages

When you locate received messages in the General or private
mailboxes, you can listen to them.

1 Open the General folder.

2 To playback the message, select it, and click Play (or press
Return or Enter).

New message icons are white. Once opened, they turn gray.
In the following example, a new 15 second message was
received at 6:01 AM, added to those already received.

Your Macintosh plays the message.

Deleting messages

1 To delete a message, select it, then click Delete.

An alert dialog asks you to confirm.

Adding a comment

To keep track of messages you can attach a comment.

1 To enter a comment, select a message, then choose
Comment in the Messages menu (or use the x-I keyboard
equivalent).

The comment dialog box appears.

2 Type your comments, then click OK.
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Setting a password for the General mailbox

To retrieve and replay messages from the General mailbox
remotely (from another phone), you must set a password.
This ensures that only you can retrieve your messages.

1 Select the General folder and choose Modify Message Box in
the Messages menu.

2 Type a four digit password in the Password field, then 
click Modify.
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Private mailboxes

Private mailboxes are subordinate to the General mailbox.
You can create up to nine private mailboxes, each one with
its own greeting and message capabilities.

To create a private mailbox

1 Choose Create Message Box in the Messages menu.

2 When the Create Message Box dialog box appears, fill in the
requested information.

For example, you can name this box Lester, give it a unique
four digit password and access code (1–9), and record its
custom greeting (use the method for General greeting).

When a caller dials in, the General mailbox always answers
first. For example, the General greeting might be: “Good
Morning, you have reached XYZ Company. To leave a
message for Lester, press 7. To leave a message for Patti,
press 9.”

If a caller presses 9, Patti’s message plays, “To record a
message for Patti, begin after the beep.” If the caller leaves a
message, it is recorded in Patti’s mailbox and only Patti or a
person who knows her password may retrieve it.
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What the caller hears

When a caller dials your number, he or she hears the
General mailbox greeting. The caller may leave a message in
the General mailbox after the beep at the end of the general
greeting or, to leave a message in a private mailbox, press
the code (1–9) for the appropriate mailbox before or during
the general greeting, and then leave a message after the
second beep.

Creating a special announcement

A private mailbox can be used to play special information
announcements for incoming callers.

1 Choose Modify Message Box and click Answering only.

This creates a private mailbox which cannot record messages
and whose greeting is used as an announcement.

See also:  “Recording a greeting” for more information.

Sorting messages

Messages can be sorted by using the Messages menu or by
clicking on date, time or duration.

Moving a message

By pressing the wrong code, a caller may leave a message in
the wrong mailbox. You can drag it into the correct mailbox.
The origin and date and time of transfer appear in the
Comment field.

Note: The transfer is really a copy; the original message
remains in the mailbox that received it. If you want to
remove the original, you must delete it.
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Remote retrieval of messages

Messages can be retrieved remotely with the aid of a 
Touch-Tone telephone handset or Touch-Tone generator.

From the General mailbox

1 To retrieve your messages from the General mailbox, press *
followed by the four digit password while the greeting 
is playing.

All messages in the General mailbox are replayed.

From a private mailbox

1 To access a private mailbox, press the remote access code
(1–9) during the General greeting.

2 Then, press * followed by the four digit mailbox password
during the private mailbox greeting.

Two beeps confirm that the password has been correctly
received; all messages in that particular mailbox are then
replayed.
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During playback you can send the following commands 
from the telephone handset:

1 Replay all messages

2 Stop message replay

3 Delete the current message 
(erases the message from your disk)

4 Return to the beginning of current message

5 Stop message replay

6 Go to next message

7 Reserved for future use

8 Reserved for future use

9 Reserved for future use

Important While receiving a message, AppleTel will stop
recording after a period of silence (length varies according to
country) or after busy tone or dial tone detection. You can
set the maximum length of a message from 1 second to 6
minutes (360 seconds) in the AppleTel Preferences. (The
maximum length is lower in some countries.)
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AppleTel Preferences

You can set up AppleTel according to your particular needs
using the options in the Preferences dialog.

To set Preferences

1 Choose Preferences from the Edit menu.

The Preferences dialog appears.

2 Check “Show Voice Mail window on incoming call” if you
want the Voice Mail window to open automatically when you
receive a call. 

This setting merely controls the window display; it does not
affect the functionality of Voice Mail. You can still receive
messages even if the window is not shown, or even when
AppleTel is not open.

3 Use the arrows to set the duration limit for incoming
messages. Longer messages require more space on your
hard disk. 

You might want to mention the message limit in your
greeting, for example, “You can leave a message of up to two
minutes after the beep”. The range is from 1 second to 6
minutes (360 seconds).The maximum length is lower in
some countries.
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4 Select the appropriate modem type from the modem pop-up
menu and select the port to which your modem is attached
from the port pop-up menu. For example, if you are using
AppleTel with an external modem, select your modem type
from the modem pop-up menu and select the port (modem
or printer) to which it is attached from the port pop-up
menu. If you select an internal modem from the modem
pop-up menu, the selection of the correct port (internal) is
automatic and the port selection pop-up menu does not
appear.

5 Select tone or pulse dialing mode according to your
telephone system.

6 Check Auto-Answer to activate Voice Mail to answer
incoming calls. If you leave this unchecked, Voice Mail is
“off” and does not answer incoming calls (though you can
still dial outgoing calls).

7 Set the number of rings for auto-answer using the up and
down arrows. This setting is fixed and may not be changed in
some countries. In countries where the setting is variable,
you should keep in mind that callers are accustomed to calls
being answered within about 10 seconds and most will hang
up if their call is not answered within 45 seconds. In a
normal setting, your caller should hear your greeting within
about 15 seconds of the first ring.

Note AppleTel takes priority over Fax Terminal if the
number of rings for auto-answer setting is different.

When you are satisfied with the settings, click OK. Your
preferences take effect immediately and remain in effect
until you change them.
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